Дебютировавший на прошлой неделе джейлбрейк для iOS 9.3.3 стал для многих самым ожидаемым событием лета. Пользователи iPhone и iPad, наконец, получили доступ к программному обеспечению, которое отсутствует в официальных источниках. Тем не менее после использования эксплоита выяснилось, что многие интерфейсные надстройки и неофициальные расширения не совместимы c iOS 9.

Cybstrate-1

По опыту использования джейлбрейка, некоторые твики имеют свойство пропадать с устройств после перезагрузки или приводить к сбоям, вызывая случайные перезагрузки. Некоторые пользователи сообщают об ошибке «failed in buffer_write(fd) (8, ret=-1)» при работе со взломанными девайсами.

Нестабильная работа твиков из Cydia объясняется ограниченной совместимостью с iOS 9.3.3 основного фреймворка MobileSubstrate, обеспечивающего работу большинства аддонов. Из-за спешки разработчиков создатель джейлбрейк-магазина Джей «Saurik» Фриман не успел обновить фреймворк. И вот теперь, спустя 4 дня после релиза, вышла официальная заплатка.

«Cydia Substrate 0.9.6200 для iOS 9.2+ решает проблемы джейлбрейка: ошибку файловой системы при использовании «полупривязанного джейлбрейка» (мой любимый термин) путем складирования установочных целей джейлбрейк-расширений», – написал Фриман.

Cybstrate-2

Официальный патч Cydia Substrate 0.9.62 обеспечивает совместимость iPhone, iPhone и iPod touch с большинством твиков из Cydia. Фриман исправил работу фреймворка: разработчики твиков получили возможность выпустить обновления совместимости, а пользователи – практически работоспособный джейлбрейк для iOS 9.3.3. Необходимо лишь обновить Cydia Substrate до версии 0.9.62.

Релиз Cydia Substrate означает, что в скором времени большинство джейлбрейк-твиков будут корректно работать на iPhone, iPod touch и iPad с iOS 9.