Хакер: в iOS 9.3 beta 5 присутствуют необходимые для джейлбрейка уязвимости

302
0

На этой неделе MacNews писал о том, что Apple в iOS 9.3 beta 5 закрыла программную уязвимость, которую предполагали использовать для подготовки джейлбрейка. Сегодня известный программист Люка Тодеско поспешил успокоить всех, кто ждет решение для взлома iPhone и iPad.

Хакер: в iOS 9.3 beta 5 присутствуют необходимые для джейлбрейка уязвимости:	Фото - 2

Еще в январе этого года Тодеско объявил об успешном джейлбрейке операционной системы iOS 9.3 beta 1. В подтверждение разработчик выложил видеоролик, демонстрирующий магазин Cydia на рабочем столе iPhone. Были опасения, что уязвимость, которую устранила Apple в пятой бета-версии, нарушит работу джейлбрейка. Однако, по словам Тодеско, созданный им джейлбрейк работает и в свежей сборке iOS.

В переписке со Стефаном Эссером хакер подтвердил, что используемый им эксплоит поддерживает iOS 9.3 beta 5. «Я пока ничего не заметил, мой код работал», — написал Тодеско.

Хакер: в iOS 9.3 beta 5 присутствуют необходимые для джейлбрейка уязвимости:	Фото - 2

Стоит отметить, что Люка Тодеско ранее говорил, что не планирует выпускать эксплоит. Тем не менее, это не исключает возможности того, что хакер передаст обнаруженные им уязвимости другим разработчикам. В прошлом году Тодеско помог хакерской группе Pangu выпустить джейлбрейк для iOS 9.1.

Заявлений от Pangu по поводу джейлбрейка iOS 9.3 пока не поступало. Ранее осведомленные источники сообщали, что релиз инструментов для взлома должен состояться вслед за выходом финальной версии ОС.

На данный момент не существует публично доступных джейлбрейк-эксплоитов для iPhone и iPad, работающих под управлением iOS 9.2.1. В прошлом году Pangu опубликовала инструмент для взлома iOS 9, но в обновлении iOS 9.1 разработчики Apple устранили используемые уязвимости.